Browse over 9,000 car reviews

Sorry, there are no cars that match your search

Vince ASKED THE GUIDE

2019 Mercedes-AMG C43: Lacking power when accelerating

I have a 2019 AMG C43. The car stutters and lacks power when accelerating from stationary. At worst it kangaroo-hops but no fault is detected on the computer.

Colleagues of mine have noted that the C43 isn’t at its happiest when taking off from a standing start sometimes, particularly if the stop-start function is engaged. That said, the harshest description of the problem was the odd clunk when launching the car, but even with that system switched off, the AMG sometimes seems to have problems deciding which gear to select, leading to a lack of smoothness. Perhaps it’s not helped by the fact that the car is all-wheel-drive, and grips the road extremely well when perhaps a little `give’ in the driveline mightn’t be a bad thing. Maybe it’s the traction-control stepping in too early and interrupting the flow of power to the wheels.

That said, your problem sounds a lot more severe than that. The C43 uses a conventional torque converter automatic transmission, so it doesn’t suffer some of the jerkiness that other cars using dual-clutch technology can. It’s puzzling though, that the computer isn’t throwing up any fault codes, so maybe your car is simply doing what some C43s do to a greater or lesser extent. If it’s as bad as you say, it’s not good enough and you should pursue the problem with Mercedes-Benz and have the problem corrected under warranty.

Comments